summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/simpleqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/simpleqml/CMakeLists.txt')
-rw-r--r--examples/activeqt/simpleqml/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/examples/activeqt/simpleqml/CMakeLists.txt b/examples/activeqt/simpleqml/CMakeLists.txt
new file mode 100644
index 0000000..bc293ad
--- /dev/null
+++ b/examples/activeqt/simpleqml/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Generated from simpleqml.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(simpleqmlax LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/simpleqml")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS AxServer)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS QuickWidgets)
+
+add_qt_gui_executable(simpleqmlax
+ main.cpp
+)
+target_link_libraries(simpleqmlax PUBLIC
+ Qt::AxServer
+ Qt::Core
+ Qt::Gui
+ Qt::Quick
+ Qt::QuickWidgets
+ Qt::Widgets
+)
+
+
+# Resources:
+set(simpleqml_resource_files
+ "main.qml"
+)
+
+qt6_add_resources(simpleqmlax "simpleqml"
+ PREFIX
+ "/"
+ FILES
+ ${simpleqml_resource_files}
+)
+
+install(TARGETS simpleqmlax
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)