summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/wrapper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/wrapper/CMakeLists.txt')
-rw-r--r--examples/activeqt/wrapper/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/examples/activeqt/wrapper/CMakeLists.txt b/examples/activeqt/wrapper/CMakeLists.txt
new file mode 100644
index 0000000..4a43092
--- /dev/null
+++ b/examples/activeqt/wrapper/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from wrapper.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(wrapperax LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/wrapper")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS AxServer)
+
+add_qt_gui_executable(wrapperax
+ main.cpp
+)
+target_link_libraries(wrapperax PUBLIC
+ Qt::AxServer
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS wrapperax
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)