summaryrefslogtreecommitdiffstats
path: root/examples/applicationmanager/application-features/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-06-21 16:25:49 +0200
committerDominik Holland <dominik.holland@qt.io>2021-06-28 15:32:27 +0200
commit37d87aa343f0367ab9e8456296f423031c21bb34 (patch)
tree54203785438b9e445107e73a784988a1cb82a102 /examples/applicationmanager/application-features/CMakeLists.txt
parent5784707989188dc9a60f7c6d4f76c20a59b3368d (diff)
Make all qml-only examples usable from within QtCreator
This adds a new qt6_am_add_systemui_wrapper cmake function which generates a wrapper script and makes sure this is callable from within QtCreator. Change-Id: I8270d31167ef5572514d294d634f55962af04355 Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/applicationmanager/application-features/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/application-features/CMakeLists.txt16
1 files changed, 6 insertions, 10 deletions
diff --git a/examples/applicationmanager/application-features/CMakeLists.txt b/examples/applicationmanager/application-features/CMakeLists.txt
index 4df08997..6594ddb6 100644
--- a/examples/applicationmanager/application-features/CMakeLists.txt
+++ b/examples/applicationmanager/application-features/CMakeLists.txt
@@ -1,7 +1,7 @@
# Generated from application-features.pro.
cmake_minimum_required(VERSION 3.14)
-project(ui LANGUAGES CXX)
+project(application-features LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -15,16 +15,12 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/applicationmanager/application-features")
-)
-set_target_properties(ui PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
+find_package(Qt6 COMPONENTS AppManMainPrivate)
-install(TARGETS ui
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+qt6_am_add_systemui_wrapper(application-features
+ CONFIG_YAML am-config.yaml
+ EXTRA_FILES apps system-ui
)
+
add_subdirectory(imports)
add_subdirectory(native)