summaryrefslogtreecommitdiffstats
path: root/examples/applicationmanager/frame-timer/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-06-21 16:25:49 +0200
committerDominik Holland <dominik.holland@qt.io>2021-06-28 15:32:27 +0200
commit37d87aa343f0367ab9e8456296f423031c21bb34 (patch)
tree54203785438b9e445107e73a784988a1cb82a102 /examples/applicationmanager/frame-timer/CMakeLists.txt
parent5784707989188dc9a60f7c6d4f76c20a59b3368d (diff)
Make all qml-only examples usable from within QtCreator
This adds a new qt6_am_add_systemui_wrapper cmake function which generates a wrapper script and makes sure this is callable from within QtCreator. Change-Id: I8270d31167ef5572514d294d634f55962af04355 Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/applicationmanager/frame-timer/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/frame-timer/CMakeLists.txt18
1 files changed, 4 insertions, 14 deletions
diff --git a/examples/applicationmanager/frame-timer/CMakeLists.txt b/examples/applicationmanager/frame-timer/CMakeLists.txt
index bb6e0a97..45525f5d 100644
--- a/examples/applicationmanager/frame-timer/CMakeLists.txt
+++ b/examples/applicationmanager/frame-timer/CMakeLists.txt
@@ -17,19 +17,9 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/applicationmanager/frame-timer")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS AppManMainPrivate)
-)
-set_target_properties(frame-timer PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(frame-timer PUBLIC
- Qt::Core
- Qt::Gui
-)
-
-install(TARGETS frame-timer
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+qt6_am_add_systemui_wrapper(frame-timer
+ CONFIG_YAML am-config.yaml
+ EXTRA_FILES apps system-ui
)