summaryrefslogtreecommitdiffstats
path: root/examples/applicationmanager/intents/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-06-21 16:25:49 +0200
committerDominik Holland <dominik.holland@qt.io>2021-06-28 15:32:27 +0200
commit37d87aa343f0367ab9e8456296f423031c21bb34 (patch)
tree54203785438b9e445107e73a784988a1cb82a102 /examples/applicationmanager/intents/CMakeLists.txt
parent5784707989188dc9a60f7c6d4f76c20a59b3368d (diff)
Make all qml-only examples usable from within QtCreator
This adds a new qt6_am_add_systemui_wrapper cmake function which generates a wrapper script and makes sure this is callable from within QtCreator. Change-Id: I8270d31167ef5572514d294d634f55962af04355 Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/applicationmanager/intents/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/intents/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/applicationmanager/intents/CMakeLists.txt b/examples/applicationmanager/intents/CMakeLists.txt
new file mode 100644
index 00000000..b5b69ee0
--- /dev/null
+++ b/examples/applicationmanager/intents/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from intents.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(intents LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/applicationmanager/intents")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS AppManMainPrivate)
+
+qt6_am_add_systemui_wrapper(intents
+ MAIN_QML_FILE system-ui.qml
+ EXTRA_FILES apps shared
+ EXTRA_ARGS --builtin-apps-manifest-dir apps
+)