summaryrefslogtreecommitdiffstats
path: root/examples/applicationmanager/application-features/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/applicationmanager/application-features/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/application-features/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/applicationmanager/application-features/CMakeLists.txt b/examples/applicationmanager/application-features/CMakeLists.txt
new file mode 100644
index 00000000..4df08997
--- /dev/null
+++ b/examples/applicationmanager/application-features/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from application-features.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(ui LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/applicationmanager/application-features")
+
+)
+set_target_properties(ui PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+install(TARGETS ui
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)
+add_subdirectory(imports)
+add_subdirectory(native)