summaryrefslogtreecommitdiffstats
path: root/examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt b/examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt
new file mode 100644
index 00000000..945ad301
--- /dev/null
+++ b/examples/applicationmanager/application-features/imports/terminator2/CMakeLists.txt
@@ -0,0 +1,48 @@
+# Generated from terminator2.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(terminator2plugin LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/applicationmanager/application-features/apps/crash/Terminator")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+qt6_add_qml_module(terminator2plugin
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CURRENT_BINARY_DIR}/../../apps/crash/Terminator"
+ VERSION 1.0
+ URI "Terminator"
+ INSTALL_LOCATION ${INSTALL_EXAMPLEDIR}
+)
+
+target_sources(terminator2plugin PRIVATE
+ qmlterminator2.cpp qmlterminator2.h
+)
+set_target_properties(terminator2plugin PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(terminator2plugin PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+install(TARGETS terminator2plugin
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)