summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/stackwalker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/stackwalker/CMakeLists.txt')
-rw-r--r--src/3rdparty/stackwalker/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/3rdparty/stackwalker/CMakeLists.txt b/src/3rdparty/stackwalker/CMakeLists.txt
new file mode 100644
index 00000000..3d29945c
--- /dev/null
+++ b/src/3rdparty/stackwalker/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from stackwalker.pro.
+
+#####################################################################
+## BundledStackwalker Generic Library:
+#####################################################################
+
+qt_internal_add_3rdparty_library(BundledStackwalker
+ QMAKE_LIB_NAME stackwalker
+ STATIC
+ INSTALL
+ SOURCES
+ stackwalker.cpp stackwalker.h
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ PUBLIC_INCLUDE_DIRECTORIES
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+)
+qt_disable_warnings(BundledStackwalker)
+qt_set_symbol_visibility_hidden(BundledStackwalker)
+
+#### Keys ignored in scope 1:.:.:stackwalker.pro:<TRUE>:
+# QMAKE_CFLAGS = "/D_CRT_SECURE_NO_WARNINGS"
+# TEMPLATE = "lib"
+# _REQUIREMENTS = "windows && msvc"