summaryrefslogtreecommitdiffstats
path: root/src/common-lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common-lib/CMakeLists.txt')
-rw-r--r--src/common-lib/CMakeLists.txt77
1 files changed, 77 insertions, 0 deletions
diff --git a/src/common-lib/CMakeLists.txt b/src/common-lib/CMakeLists.txt
new file mode 100644
index 00000000..75d795d5
--- /dev/null
+++ b/src/common-lib/CMakeLists.txt
@@ -0,0 +1,77 @@
+# Generated from common-lib.pro.
+
+#####################################################################
+## AppManCommon Module:
+#####################################################################
+
+qt_find_package(WrapLibYaml PROVIDED_TARGETS WrapLibYaml::WrapLibYaml)
+
+# temporary hack to get around the "#pragma once not allowed in cpp" error
+set(QT_FEATURE_headersclean FALSE)
+
+qt_internal_add_module(AppManCommonPrivate
+ CONFIG_MODULE_NAME appman_common
+ STATIC
+ EXCEPTIONS
+ INTERNAL_MODULE
+ SOURCES
+ configcache.cpp configcache.h configcache_p.h
+ crashhandler.cpp crashhandler.h
+ dbus-utilities.cpp
+ error.h
+ exception.cpp exception.h
+ global.h
+ logging.cpp logging.h
+ processtitle.cpp processtitle.h
+ qml-utilities.cpp qml-utilities.h
+ qtyaml.cpp qtyaml.h
+ startuptimer.cpp startuptimer.h
+ unixsignalhandler.cpp unixsignalhandler.h
+ utilities.cpp utilities.h
+ PUBLIC_LIBRARIES
+ Qt::Concurrent
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Network
+ Qt::Qml
+ Qt::QmlPrivate
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION TARGET Qt::GeniviExtras
+ DEFINES
+ AM_GENIVIEXTRAS_LAZY_INIT
+ PUBLIC_LIBRARIES
+ Qt::GeniviExtras
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION TARGET Qt::DBus
+ SOURCES
+ dbus-utilities.h
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION LINUX
+ PUBLIC_LIBRARIES
+ dl
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION QT_FEATURE_libbacktrace
+ LIBRARIES
+ Qt::BundledBacktrace
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION QT_FEATURE_stackwalker
+ LIBRARIES
+ Qt::BundledStackwalker
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION QT_FEATURE_system_libyaml
+ LIBRARIES
+ WrapLibYaml::WrapLibYaml
+)
+
+qt_internal_extend_target(AppManCommonPrivate CONDITION NOT QT_FEATURE_system_libyaml
+ LIBRARIES
+ Qt::BundledLibYaml
+)