summaryrefslogtreecommitdiffstats
path: root/src/intent-server-lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/intent-server-lib/CMakeLists.txt')
-rw-r--r--src/intent-server-lib/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/intent-server-lib/CMakeLists.txt b/src/intent-server-lib/CMakeLists.txt
new file mode 100644
index 00000000..30a6b020
--- /dev/null
+++ b/src/intent-server-lib/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from intent-server-lib.pro.
+
+#####################################################################
+## AppManIntentServer Module:
+#####################################################################
+
+# temporary hack to get around the "#pragma once not allowed in cpp" error
+set(QT_FEATURE_headersclean FALSE)
+
+qt_internal_add_module(AppManIntentServerPrivate
+ CONFIG_MODULE_NAME appman_intent_server
+ STATIC
+ EXCEPTIONS
+ INTERNAL_MODULE
+ SOURCES
+ intent.cpp intent.h
+ intentmodel.cpp intentmodel.h
+ intentserver.cpp intentserver.h
+ intentserverrequest.cpp intentserverrequest.h
+ intentserversysteminterface.cpp intentserversysteminterface.h
+ LIBRARIES
+ Qt::AppManCommonPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Network
+ Qt::Qml
+)