summaryrefslogtreecommitdiffstats
path: root/src/notification-lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/notification-lib/CMakeLists.txt')
-rw-r--r--src/notification-lib/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/notification-lib/CMakeLists.txt b/src/notification-lib/CMakeLists.txt
new file mode 100644
index 00000000..b60ffac0
--- /dev/null
+++ b/src/notification-lib/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Generated from notification-lib.pro.
+
+#####################################################################
+## AppManNotification Module:
+#####################################################################
+
+# temporary hack to get around the "#pragma once not allowed in cpp" error
+set(QT_FEATURE_headersclean FALSE)
+
+qt_internal_add_module(AppManNotificationPrivate
+ CONFIG_MODULE_NAME appman_notification
+ STATIC
+ EXCEPTIONS
+ INTERNAL_MODULE
+ SOURCES
+ notification.cpp notification.h
+ LIBRARIES
+ Qt::AppManCommonPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)