summaryrefslogtreecommitdiffstats
path: root/src/plugin-interfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin-interfaces/CMakeLists.txt')
-rw-r--r--src/plugin-interfaces/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/plugin-interfaces/CMakeLists.txt b/src/plugin-interfaces/CMakeLists.txt
new file mode 100644
index 00000000..21584521
--- /dev/null
+++ b/src/plugin-interfaces/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Generated from plugin-interfaces.pro.
+
+#####################################################################
+## AppManPluginInterfaces Module:
+#####################################################################
+
+# temporary hack to get around the "#pragma once not allowed in cpp" error
+set(QT_FEATURE_headersclean FALSE)
+
+qt_internal_add_module(AppManPluginInterfacesPrivate
+ CONFIG_MODULE_NAME appman_plugininterfaces
+ STATIC
+ EXCEPTIONS
+ INTERNAL_MODULE
+ SOURCES
+ containerinterface.cpp containerinterface.h
+ startupinterface.cpp startupinterface.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+)