summaryrefslogtreecommitdiffstats
path: root/src/tools/launcher-qml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/launcher-qml/CMakeLists.txt')
-rw-r--r--src/tools/launcher-qml/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/tools/launcher-qml/CMakeLists.txt b/src/tools/launcher-qml/CMakeLists.txt
new file mode 100644
index 00000000..60da4b95
--- /dev/null
+++ b/src/tools/launcher-qml/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from launcher-qml.pro.
+
+#####################################################################
+## appman-launcher-qml Tool:
+#####################################################################
+
+qt_get_tool_target_name(target_name appman-launcher-qml)
+qt_internal_add_tool(${target_name}
+ EXCEPTIONS
+ TOOLS_TARGET AppManMainPrivate
+ SOURCES
+ launcher-qml.cpp launcher-qml_p.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::DBus
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickPrivate
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManLauncherPrivate
+ Qt::AppManMonitorPrivate
+ Qt::AppManNotificationPrivate
+ Qt::AppManPluginInterfacesPrivate
+ Qt::AppManSharedMainPrivate
+)
+
+#### Keys ignored in scope 1:.:.:launcher-qml.pro:<TRUE>:
+# TEMPLATE = "app"