summaryrefslogtreecommitdiffstats
path: root/tests/auto/application/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/application/CMakeLists.txt')
-rw-r--r--tests/auto/application/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/application/CMakeLists.txt b/tests/auto/application/CMakeLists.txt
new file mode 100644
index 00000000..942bc0c3
--- /dev/null
+++ b/tests/auto/application/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+qt_internal_add_test(tst_application
+ SOURCES
+ ../error-checking.h
+ tst_application.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManManagerPrivate
+)
+
+# Resources:
+set(tst_application_resource_files
+ "info.yaml"
+)
+
+qt_internal_add_resource(tst_application "tst_application"
+ PREFIX
+ "/"
+ FILES
+ ${tst_application_resource_files}
+)
+
+qt_internal_extend_target(tst_application CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)