summaryrefslogtreecommitdiffstats
path: root/tests/auto/cryptography/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cryptography/CMakeLists.txt')
-rw-r--r--tests/auto/cryptography/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/cryptography/CMakeLists.txt b/tests/auto/cryptography/CMakeLists.txt
new file mode 100644
index 00000000..4cc87a7d
--- /dev/null
+++ b/tests/auto/cryptography/CMakeLists.txt
@@ -0,0 +1,20 @@
+
+qt_internal_add_test(tst_cryptography
+ SOURCES
+ ../error-checking.h
+ tst_cryptography.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManCommonPrivate
+ Qt::AppManCryptoPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_cryptography CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)