summaryrefslogtreecommitdiffstats
path: root/tests/auto/installationreport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/installationreport/CMakeLists.txt')
-rw-r--r--tests/auto/installationreport/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/installationreport/CMakeLists.txt b/tests/auto/installationreport/CMakeLists.txt
new file mode 100644
index 00000000..f0204d00
--- /dev/null
+++ b/tests/auto/installationreport/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+qt_internal_add_test(tst_installationreport
+ SOURCES
+ ../error-checking.h
+ tst_installationreport.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManCryptoPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_installationreport CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)