summaryrefslogtreecommitdiffstats
path: root/tests/auto/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/main/CMakeLists.txt')
-rw-r--r--tests/auto/main/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/auto/main/CMakeLists.txt b/tests/auto/main/CMakeLists.txt
new file mode 100644
index 00000000..05e6d2cd
--- /dev/null
+++ b/tests/auto/main/CMakeLists.txt
@@ -0,0 +1,39 @@
+
+qt_internal_add_test(tst_main
+ SOURCES
+ ../error-checking.h
+ tst_main.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManIntentServerPrivate
+ Qt::AppManMainPrivate
+ Qt::AppManManagerPrivate
+)
+
+# Resources:
+set(main_resource_files
+ "dummy.qml"
+)
+
+qt_internal_add_resource(tst_main "main"
+ PREFIX
+ "/foo"
+ FILES
+ ${main_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:main.pro:<TRUE>:
+# OTHER_FILES = "am-config.yaml"
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_main CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)