summaryrefslogtreecommitdiffstats
path: root/tests/auto/packageextractor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/packageextractor/CMakeLists.txt')
-rw-r--r--tests/auto/packageextractor/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/packageextractor/CMakeLists.txt b/tests/auto/packageextractor/CMakeLists.txt
new file mode 100644
index 00000000..9775d7a3
--- /dev/null
+++ b/tests/auto/packageextractor/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+qt_internal_add_test(tst_packageextractor
+ SOURCES
+ ../error-checking.h
+ tst_packageextractor.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManPackagePrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_packageextractor CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)