summaryrefslogtreecommitdiffstats
path: root/tests/auto/processreader/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/processreader/CMakeLists.txt')
-rw-r--r--tests/auto/processreader/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/auto/processreader/CMakeLists.txt b/tests/auto/processreader/CMakeLists.txt
new file mode 100644
index 00000000..5e60adfc
--- /dev/null
+++ b/tests/auto/processreader/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+qt_internal_add_test(tst_processreader
+ SOURCES
+ ../error-checking.h
+ tst_processreader.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManApplicationPrivate
+ Qt::AppManCommonPrivate
+ Qt::AppManManagerPrivate
+ Qt::AppManMonitorPrivate
+ Qt::AppManWindowPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_processreader CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)