summaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/resources/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/resources/CMakeLists.txt')
-rw-r--r--tests/auto/qml/resources/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/auto/qml/resources/CMakeLists.txt b/tests/auto/qml/resources/CMakeLists.txt
new file mode 100644
index 00000000..0893a7ac
--- /dev/null
+++ b/tests/auto/qml/resources/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from resources.pro.
+
+#####################################################################
+## systemuiplugin Generic Library:
+#####################################################################
+
+qt_internal_add_cmake_library(systemuiplugin
+ MODULE
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
+)
+
+# Resources:
+set(systemuiplugin_resource_files
+ "qml/widgets/MagentaRect.qml"
+)
+
+qt_internal_add_resource(systemuiplugin "systemuiplugin"
+ PREFIX
+ "/"
+ FILES
+ ${systemuiplugin_resource_files}
+)
+
+
+#### Keys ignored in scope 2:.:.:test.pro:<TRUE>:
+# AM_CONFIG = "am-config.yaml"
+# DIRECTORIES = "apps/app2/qml" "relative"
+# FILES = "am-config.yaml" "apps/app1/icon.png" "apps/app1/info.yaml" "apps/app2/icon.png" "apps/app2/info.yaml"
+# RESOURCE_SOURCE = "systemuifile.qrc"
+# TEMPLATE = "lib"
+# TEST_APPS = "app1" "app2"
+# TEST_FILES = "tst_resource.qml"
+
+qt_autogen_tools_initial_setup(systemuiplugin)
+add_subdirectory(appcommon)
+add_subdirectory(apps/app1)
+add_subdirectory(apps/app2)