summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBogDan Vatra <bogdan@kde.org>2014-10-16 11:02:08 +0300
committerBogDan Vatra <bogdan@kde.org>2014-10-19 11:38:33 +0200
commitc5b0308dc562880cdcf55d8f86cad11769e65155 (patch)
tree7645583321dfaf9f756bc9282ff36c7b070ba579
parente5f48c63d2c6f9a6c4f8a21bcf634111e002ae5b (diff)
Android: Update Ministro's requirements.
Task-number: QTBUG-41968 Change-Id: Ia0c204dd87b9de3cbb7bb388099c435b855ad4d5 Reviewed-by: Paul Olav Tvete <paul.tvete@digia.com>
-rw-r--r--src/android/java/src/org/qtproject/qt5/android/bindings/QtActivity.java2
-rw-r--r--src/android/templates/res/values/libs.xml2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/android/java/src/org/qtproject/qt5/android/bindings/QtActivity.java b/src/android/java/src/org/qtproject/qt5/android/bindings/QtActivity.java
index e526c0a210..0c52bc7530 100644
--- a/src/android/java/src/org/qtproject/qt5/android/bindings/QtActivity.java
+++ b/src/android/java/src/org/qtproject/qt5/android/bindings/QtActivity.java
@@ -99,7 +99,7 @@ import android.view.ActionMode.Callback;
public class QtActivity extends Activity
{
private final static int MINISTRO_INSTALL_REQUEST_CODE = 0xf3ee; // request code used to know when Ministro instalation is finished
- private static final int MINISTRO_API_LEVEL = 4; // Ministro api level (check IMinistro.aidl file)
+ private static final int MINISTRO_API_LEVEL = 5; // Ministro api level (check IMinistro.aidl file)
private static final int NECESSITAS_API_LEVEL = 2; // Necessitas api level used by platform plugin
private static final int QT_VERSION = 0x050100; // This app requires at least Qt version 5.1.0
diff --git a/src/android/templates/res/values/libs.xml b/src/android/templates/res/values/libs.xml
index 664ab0abec..4d68673cb0 100644
--- a/src/android/templates/res/values/libs.xml
+++ b/src/android/templates/res/values/libs.xml
@@ -1,7 +1,7 @@
<?xml version='1.0' encoding='utf-8'?>
<resources>
<array name="qt_sources">
- <item>https://download.qt-project.org/ministro/android/qt5/qt-5.3</item>
+ <item>https://download.qt-project.org/ministro/android/qt5/qt-5.4</item>
</array>
<!-- The following is handled automatically by the deployment tool. It should