summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:14 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-04-24 14:20:25 +0200
commitf3c10280f59d35fbf0862e6e353602e7aa8ef901 (patch)
tree06af7491abdf9743014e3392a1ea1189ce470c97 /CMakeLists.txt
parenta92c202b49777696cbc64003f6292e6b61952140 (diff)
Introduce the qt_internal_project_setup macro
The macro sets the required CMake variables and policies and should be called right after the find_package(Qt6 COMPONENTS BuildInternals... call to make sure that the subsequent code adopt all the required policies. Pick-to: 6.5 Task-number: QTBUG-112685 Change-Id: I9f93f728ee4d8ae7743db9fffafa26025c76dcf2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 628c01f8d1..f4d7b44159 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,6 +107,8 @@ else()
find_package(Qt6 REQUIRED COMPONENTS BuildInternals CMAKE_FIND_ROOT_PATH_BOTH)
endif()
+qt_internal_project_setup()
+
qt_build_repo_begin()
if(NOT QT_BUILD_STANDALONE_TESTS)