summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-08-20 10:19:32 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-08-20 17:07:53 +0200
commit729d102b1c5273087c54d1584c80f1a1e6eef86c (patch)
tree1d5ab5f1d52d29f148a1615f2316f3d953089d5c /CMakeLists.txt
parent2f1a55c0b13ea02619f0d209a2b710fb7cbe8a1a (diff)
CMake: Implement configure -optimize-debug
Task-number: QTBUG-85373 Change-Id: I3aba1fcf96e36544dd75a5e6adc5f770a9a45726 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10df970dff..e31224ee4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,6 +118,9 @@ endif()
qt_build_repo_end()
+# This function must be called after the QT_FEATURE_xxx variables have been set up.
+qt_internal_set_up_config_optimizations_like_in_qmake()
+
if(NOT QT_BUILD_STANDALONE_TESTS AND BUILD_EXAMPLES)
add_subdirectory(examples)
if(QT_NO_MAKE_EXAMPLES)