summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-15 13:57:15 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-15 17:33:51 +0000
commit9542e78525b422159406d8fa63e30dcd0f926411 (patch)
tree9b6b90610897ca19389c4ab6a621dbcce812bf56 /CMakeLists.txt
parentc097256ee4b207284148a8026bb29fc4453efeae (diff)
Use the qt_build_repo() macros for building qtbase as well
To implement this, create a new Qt5BuildInternals package. All child Qt modules like qtsvg should use find_package(Qt5BuildInternals) or find_package(Qt5 COMPONENTS BuildInternals) in the their top level CMakeLists.txt. This will make the qt_build_repo() macros available. For qtbase we slightly cheat, and specify a CMAKE_PREFIX_PATH pointing to the source folder that contains the BuildInternals package. For the other modules we actually use a configured and installed package Config file. This change moves variables that used to be written into the QtCore Config file into the BuildInternals package. This way things that are relevant only for building additional Qt modules does not pollute the QtCore package. Task-number: QTBUG-75580 Change-Id: I5479adff2f7903c9c2862d28c05c7f485ce3e4eb Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 7 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecc88a27e3..f0a8ef2a96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,11 +14,13 @@ list(APPEND CMAKE_MODULE_PATH
"${CMAKE_CURRENT_SOURCE_DIR}/cmake/3rdparty/kwin"
)
-## Qt specific setup common for all modules:
-include(QtSetup)
+## Find the build internals package.
+list(APPEND CMAKE_PREFIX_PATH
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake"
+)
+find_package(QtBuildInternals)
-## Enable feature summary at the end of the configure run:
-include(FeatureSummary)
+qt_build_repo_begin(SKIP_CMAKE_MODULE_PATH_ADDITION)
## QtBase specific configure tests:
include(QtBaseConfigureTests)
@@ -52,13 +54,4 @@ if (BUILD_EXAMPLES)
add_subdirectory(examples)
endif()
-## Delayed actions on some of the Qt targets:
-include(QtPostProcess)
-
-## Print a feature summary:
-feature_summary(WHAT PACKAGES_FOUND
- REQUIRED_PACKAGES_NOT_FOUND
- RECOMMENDED_PACKAGES_NOT_FOUND
- OPTIONAL_PACKAGES_NOT_FOUND
- RUNTIME_PACKAGES_NOT_FOUND
- FATAL_ON_MISSING_REQUIRED_PACKAGES)
+qt_build_repo_end()