summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-09-21 21:22:09 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-09-22 10:29:28 +0000
commitfbddf745e9011abd2838b644cbc3258572721d95 (patch)
treee15e790d2248f3687425e0474c4810f445350bab /CMakeLists.txt
parent1144c08be878a09e7de497f7bdf2316df2592cdc (diff)
Create module tools packages (config files) automatically
Previously you had to make sure to use DISABLE_TOOLS_EXPORT in an add_qt_module call if the tools are built after the module, as well as to manually call qt_export_tools after all associated tools are built. This was needlessly complex, especially for people that are porting a repo with tools for the first time. The tools package creation is now automatically done at QtPostProcess step, so there is no need to use either DISABLE_TOOLS_EXPORT or qt_export_tools() manually. DISABLE_TOOLS_EXPORT is now a no-op, and will be removed once all repos are updated not to use it. Change-Id: I965b0d3a8a0cb908afae87b047083ed7bea9f02f Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a52bed4658..4b7803da43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,9 +58,6 @@ if (QT_WILL_BUILD_TOOLS)
add_subdirectory(qmake)
endif()
-# Need to build qmake and other Core tools before exporting them.
-qt_export_tools(Core)
-
# As long as we use the mkspecs (for qplatformdefs.h), we need to always
# install it, especially when cross-compiling.
set(mkspecs_install_dir "${INSTALL_DATADIR}")