summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-15 16:39:44 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 13:53:04 +0200
commitff33883fead48137d1a9b5de5d33d8b15a585811 (patch)
tree577af0363300325beef7009434e8f8f049cdd85a /CMakeLists.txt
parentf772b8e48c91869215e2527556a95f55c1c2ad8b (diff)
CMake: Fix building examples targeting iOS simulator with qmake
The makefile generated by qmake when building an iOS example tries to execute the mkspecs/features/uikit/devices.py python script to find a simulator ID. When installing the mkspecs, we didn't preserve the source file permissions which means that the executable bit was stripped. This causes the makefile to call xcodebuild with an invalid simulator id due to not being able to execute the python script. Make sure to install the mkspecs directories preserving the source file permissions. Fixes: QTBUG-87639 Change-Id: Iaa33b740c93187155025891104e8a21c6e7c98c8 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 322e8a102a..f900ef2abc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,7 +120,8 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
foreach(entry IN LISTS mkspecs_subdirs)
if (IS_DIRECTORY ${entry})
qt_copy_or_install(DIRECTORY "${entry}"
- DESTINATION ${mkspecs_install_dir})
+ DESTINATION ${mkspecs_install_dir}
+ USE_SOURCE_PERMISSIONS)
else()
qt_copy_or_install(FILES "${entry}"
DESTINATION ${mkspecs_install_dir})