summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-12-11 11:38:20 +0100
committerTobias Hunger <tobias.hunger@qt.io>2018-12-14 14:00:21 +0000
commit42d6e5c5fa840c5c486752c4ab699e37af72c516 (patch)
treed8c3831facf2f6ee326935ef0a8c69a7cac0582a /CMakeLists.txt
parent3a8d8344e5301badd9bcef79d7f622fd16487438 (diff)
CMake: Simplify
* Only import features once * Move Core specific code into its CMakeLists.txt file * More consistently use target names like "Core" to refer to "Qt modules". We tend to require either "Core" or "QtCore" in places, which I find confusing. Change-Id: Id54161bc5468412750cb9eb7eeb15de3812e8a09 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 622cc5e00b..4f00d333dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.12.0)
+cmake_minimum_required(VERSION 3.13.0)
project(QtBase
VERSION 5.12.0