summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-11-14 13:37:52 +0100
committerTobias Hunger <tobias.hunger@qt.io>2018-11-22 08:39:12 +0000
commitf37ce9ab84400a45752787b9e015a7919c8771bd (patch)
treef8ea6bedc1dd39c36deaea764922f7cb11ff9250 /CMakeLists.txt
parent3acebfe6eb9ff0c97ab0e79f9f0b35835a4df57a (diff)
CMake: Add option to run cmake build tests
Use "cmake -DBUILD_CMAKE_TESTING=ON" to enable running cmake build system tests with ctest. Change-Id: I0a32e2d1771c9bbb0df013d0d955a9b58b1d4b79 Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9b1293843..622cc5e00b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,9 @@ include(FeatureSummary)
## QtBase specific configure tests:
include(QtBaseConfigureTests)
+## Build System tests:
+include(QtBaseCMakeTesting)
+
## Targets for global features, etc.:
include(QtBaseGlobalTargets)