summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-19 09:38:09 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-12-18 14:27:01 +0000
commit0095ff4e0659906595d281b37c3b7f89e37250af (patch)
tree8863f53ee1a5ab8e0a4cd134046baaae04def1d5 /CMakeLists.txt
parent4dfb1eca1e7768164a5687c8940aa25421adac2b (diff)
Add custom targets for documentation
Adds custom targets which take care of generating and installing documentation files. Every module has a global set of targets suffixed with the module name in order for them to be unique when we implement super builds. The targets are the same as the list below, but replace ${target} with the module's name. Eg.: docs_qtbase. For every target which has an qt_add_docs() call, we now create the following set of custom targets: * docs_${target} * html_docs_${target} * qch_docs_${target} * prepare_docs_${target} * generate_docs_${target} * install_docs_${target} * install_html_docs_${target} * install_qch_docs_${target} Fixes: QTBUG-75859 Change-Id: Ie84cb9a2dedbe7333d9a84f4d73383442deca477 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d18e91a6f4..d7874e891a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,9 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
#include CoreMacros() for qt6_generate_meta_types()
include(src/corelib/Qt6CoreMacros.cmake)
+ ## Setup documentation
+ add_subdirectory(doc)
+
## Visit all the directories:
add_subdirectory(src)
endif()