summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-01-05 12:38:22 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-01-07 18:59:47 +0000
commit4f042fafaf4266029c10359ec87b251ed7279eed (patch)
treea4e6d04a096443b104222e4ca403127e663e1200 /CMakeLists.txt
parent00a1e74522747e1220d8944fa635469ee981ee56 (diff)
Use REALPATH based check for symbolic links on Windows
Windows mount points are marked as symbolic links by CMake. So switch back to the REALPATH based check for Windows hosts. Amends dcc2704d17bda08e6dc7783559ccbfd864dd4339 Task-number: QTBUG-99416 Change-Id: Ic996db1fac5c0b5edc18728535240e272dd435e0 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: David Schulz <david.schulz@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> (cherry picked from commit b13ee89d20013ba4122e5539e9b5a0b65ee3ab6a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt42
1 files changed, 28 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c8d2f44f2..751b82a546 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,21 +14,35 @@ include(.cmake.conf)
# Bail out if any part of the build directory's path is symlinked.
function(qt_internal_check_if_path_has_symlinks path)
get_filename_component(dir "${path}" ABSOLUTE)
- while(TRUE)
- if(IS_SYMLINK "${dir}")
- message(FATAL_ERROR "The path \"${path}\" contains symlinks. \
-This is not supported. Possible solutions:
-- map directories using a transparent mechanism such as mount --bind
-- pass the real path of the build directory to CMake, e.g. using \
-cd $(realpath <path>) before invoking cmake <source_dir>.")
+ set(is_symlink FALSE)
+ if(CMAKE_HOST_WIN32)
+ # CMake marks Windows mount points as symbolic links, so use simplified REALPATH check
+ # on Windows platforms instead of IS_SYMLINK.
+ get_filename_component(dir_realpath "${dir}" REALPATH)
+ if(NOT dir STREQUAL dir_realpath)
+ set(is_symlink TRUE)
endif()
-
- set(prev_dir "${dir}")
- get_filename_component(dir "${dir}" DIRECTORY)
- if("${dir}" STREQUAL "${prev_dir}")
- return()
- endif()
- endwhile()
+ else()
+ while(TRUE)
+ if(IS_SYMLINK "${dir}")
+ set(is_symlink TRUE)
+ break()
+ endif()
+
+ set(prev_dir "${dir}")
+ get_filename_component(dir "${dir}" DIRECTORY)
+ if("${dir}" STREQUAL "${prev_dir}")
+ return()
+ endif()
+ endwhile()
+ endif()
+ if(is_symlink)
+ message(FATAL_ERROR "The path \"${path}\" contains symlinks. \
+ This is not supported. Possible solutions:
+ - map directories using a transparent mechanism such as mount --bind
+ - pass the real path of the build directory to CMake, e.g. using \
+ cd $(realpath <path>) before invoking cmake <source_dir>.")
+ endif()
endfunction()
qt_internal_check_if_path_has_symlinks("${CMAKE_BINARY_DIR}")