summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-11-18 10:27:47 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-12-02 09:02:05 +0100
commit669b454378e228e50e371387c4ce3980b44a0156 (patch)
treebe648d47e249239b5b08f88fbc757087038e7448 /CMakeLists.txt
parentbabb05c3dada87252066d2e0655878a66baacf48 (diff)
Add _make_aab target
Add target triggering AAB creation. Since the _make_aab target is not added to the ALL set, we may avoid dependency check for it and admit that the target is "always out of date". [ChangeLog][Android][Platform Specific Changes] Add the extra _make_aab targets for each executable target, that can be used to generate android app bundles. Also add aab metatarget to build all _make_aab targets that are created in the project. Fixes: QTBUG-96710 Change-Id: I3b0c7fbb5a7dd493ca7a124c4e4b91fd857386bd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit d162ce3732bc125ad42c5c5e98050a8e09ab9054)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f453505ee8..c272ab6f05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,7 +117,7 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
# Needed when building qtbase for android.
if(ANDROID)
include(src/corelib/Qt6AndroidMacros.cmake)
- _qt_internal_create_global_apk_target()
+ _qt_internal_create_global_android_targets()
endif()
if(WASM)