summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-04-28 17:46:21 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-04-30 17:44:03 +0000
commit6ffe9b1c42267eaf0fc81d16931e1a6f9f39879d (patch)
tree1691c9ce5f70ffda8f3d9afd25a9f4785c86f304 /CMakeLists.txt
parent709648993c1ea5f6b46ebe8bfd0f27d75c9b4e95 (diff)
pro2cmake.py: Generate .cmake.conf files for versioning
And create one for QtBase at the same time. Fixes: QTBUG-83835 Change-Id: Icc6b022165a57bd4e22c23bdb0016522b99a5b80 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cf6e7cac3..97fbfac421 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,9 @@ if (CMAKE_CROSSCOMPILING AND CMAKE_SYSROOT)
set(ENV{PKG_CONFIG_SYSROOT_DIR} ${CMAKE_SYSROOT})
endif()
+include(".cmake.conf")
project(QtBase
- VERSION 6.0.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt Base Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C ASM