summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-11-11 11:49:00 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-11-12 08:51:25 +0100
commitcc3f693029d6fcc65a0153b658061bd121a6af66 (patch)
tree473af6280c857efb7916147722ea868cb8213e39 /CMakeLists.txt
parent94dd2cebdcb9446626cd32a00086431eb11ab2a4 (diff)
CMake: Do not set PKG_CONFIG_* environment variables
This reverts commit 9968a211f92c2b4d5bd1fe004f16ec1c5f968dcd. The PKG_CONFIG_* environment variables should be added by the user environment, preferably by the toolchain file. Apparently, the change was added for Android before we turned off pkg-config for Android. It is not needed anymore. Change-Id: Ieeed09ae53a606c85d4937f463286b5b0f76bde9 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cdfd96f5e..f36c73b14e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,16 +27,6 @@ project(QtBase
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-if (CMAKE_CROSSCOMPILING AND CMAKE_SYSROOT)
- # When cross compiling with CMake any calls to pkg_check_modules() will
- # search into the host system instead of the target sysroot.
- # The current work around is based on the discussion found at
- # https://gitlab.kitware.com/cmake/cmake/-/merge_requests/4478
- set(ENV{PKG_CONFIG_DIR} "")
- set(ENV{PKG_CONFIG_LIBDIR} "${CMAKE_SYSROOT}/usr/lib/${CMAKE_LIBRARY_ARCHITECTURE}/pkgconfig")
- set(ENV{PKG_CONFIG_SYSROOT_DIR} ${CMAKE_SYSROOT})
-endif()
-
if(NOT QT_BUILD_STANDALONE_TESTS)
## Add some paths to check for cmake modules:
list(PREPEND CMAKE_MODULE_PATH