summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-06-21 16:45:37 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-06-24 14:23:22 +0000
commita39a0e5419b6b23721ee847f32d9668eb3c2220a (patch)
tree008d2fcdd4de59763bdbde99f10e973680600e1d /CMakeLists.txt
parent2895f3ffaa632f129232f70564a16f202ead0bda (diff)
Fix build of modules outside of QtBase when cross-compiling
The Qt::Platform target includes the mkspecs/$spec directory, which we must unconditionally install as long as we use it. Change-Id: I272650a887b5b0b3bd868524784dca65b76b02d9 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5566870576..242961b717 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,6 +72,15 @@ if (QT_WILL_BUILD_TOOLS)
add_subdirectory(qmake)
endif()
+# As long as we use the mkspecs (for qplatformdefs.h), we need to always
+# install it, especially when cross-compiling.
+set(mkspecs_install_dir "${INSTALL_DATADIR}")
+qt_path_join(mkspecs_install_dir ${QT_INSTALL_DIR} ${mkspecs_install_dir})
+
+qt_copy_or_install(DIRECTORY "${PROJECT_SOURCE_DIR}/mkspecs"
+ DESTINATION ${mkspecs_install_dir})
+
+
qt_build_repo_end()
option(BUILD_EXAMPLES "Build Qt examples" ON)