summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-09-06 11:52:47 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-09-06 18:09:18 +0000
commitbf899ba53b0407f5ef88bddb15115d4f8f03c345 (patch)
treea19eb13abe96c4231d69d8d7b6b68bb4ea8280f4 /CMakeLists.txt
parentb28c2c952850e80cc399dbba8a627a96789ffec9 (diff)
Propagate BUILD_TESTING and BUILD_EXAMPLES
As with qmake, you configure with or without -nomake tests -nomake examples, and the choice is propagated to other repositories. Do the same for CMake. It's still possible to opt out to build one or the other by passing -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF on the command line, which takes precedence over the value saved to QtBuildInternalsExtra. Change-Id: If0fbfa938d88309e7969c9bacc8d0bf86548bf5e Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 938a6f98cb..a45098efbf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,7 +69,6 @@ qt_copy_or_install(DIRECTORY "${PROJECT_SOURCE_DIR}/mkspecs"
qt_build_repo_end()
-option(BUILD_EXAMPLES "Build Qt examples" ON)
-if (BUILD_EXAMPLES)
+if(BUILD_EXAMPLES)
add_subdirectory(examples)
endif()