summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-07-24 10:11:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-07-24 09:01:24 +0000
commitf54881f73a79c74f0db5e687f44c9e1c58c865b1 (patch)
tree54452a73cadf032108f912fd0b0d0a1fd01e59e7 /CMakeLists.txt
parent42589df6b9106d7f5c9fafe504e9b895c6f86226 (diff)
Fix exporting of Core tools
It should happen after qmake is built, to make sure that the target is made global, otherwise when cross-building qtbase in another build tree, the configuration phase will fail due to not finding qmake. qmake was accidentally exported before if you configured qtbase twice, because the tool was kept around in a cache variable, the second configuration actually recreated the CoreToolsConfig.cmake file to contain qmake as well. Change-Id: I6941e83f7d6bd03c56de120fba1d18e50c4af0e4 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee24206bd7..938a6f98cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,9 @@ if (QT_WILL_BUILD_TOOLS)
add_subdirectory(qmake)
endif()
+# Need to build qmake and other Core tools before exporting them.
+qt_export_tools(Core)
+
# As long as we use the mkspecs (for qplatformdefs.h), we need to always
# install it, especially when cross-compiling.
set(mkspecs_install_dir "${INSTALL_DATADIR}")