summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJean-Michaël Celerier <jeanmichael.celerier@gmail.com>2019-06-05 10:08:44 +0200
committerJean-Michaël Celerier <jean-michael.celerier@kdab.com>2019-06-05 08:53:34 +0000
commitfecd9d90daa22b33c40a709da21cef62bfa44a15 (patch)
tree864943309ab14b3c4422cd3195ab25857d01742b /CMakeLists.txt
parentc220974ed8c6c972d43f535afa7b1bbcb1ccc5e2 (diff)
Fix static usage requirements for XcbQpa
In particular, Qt targets extended with other qt targets (eg. Qt::VulkanSupport or Qt::LinuxAccessibilitySupport) after the first add_qt_module were not taken into account when generating Depends files. Note that this patch updates the minimum required version to CMake 3.15 Change-Id: I747deedd4d59e385876bc1a834ef9bdb6078911b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d70beff2e9..8344d22c0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.14.0)
+cmake_minimum_required(VERSION 3.15.0)
project(QtBase
VERSION 5.14.0