summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 11:19:21 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-25 10:46:46 +0100
commit0446bf5ba30b83bb85144f67e8c3b151d9a8cbca (patch)
tree0d343127970efd6b6fe7919c6b80d3e61684a816 /CMakeLists.txt
parent874c6b00dd52a62633a8afb5c1749b2ab50db6b6 (diff)
CMake: Fix auto-detection of precompiled header support
PCH files were only used while building qtbase. Make sure the value is exported to the BuildInternalsConfig file, so the value is re-used when building other repositories. Also disable PCH when building simulator_and_device iOS builds, because CMake doesn't currently generate separate PCH files per architecture. Change-Id: I79955ebc557b800bc3c704deac519fe80012c229 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bc704bc73..b11c4bd93b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,9 +46,6 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
## Should this Qt be built with Werror?
option(WARNINGS_ARE_ERRORS "Build Qt with warnings as errors" ${FEATURE_developer_build})
- ## Should Qt be built using PCH?
- option(BUILD_WITH_PCH "Build Qt using precompiled headers?" ON)
-
## QtBase specific configure tests:
include(QtBaseConfigureTests)