summaryrefslogtreecommitdiffstats
path: root/cmake/tests/features/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-11-14 13:37:52 +0100
committerTobias Hunger <tobias.hunger@qt.io>2018-11-22 08:39:12 +0000
commitf37ce9ab84400a45752787b9e015a7919c8771bd (patch)
treef8ea6bedc1dd39c36deaea764922f7cb11ff9250 /cmake/tests/features/CMakeLists.txt
parent3acebfe6eb9ff0c97ab0e79f9f0b35835a4df57a (diff)
CMake: Add option to run cmake build tests
Use "cmake -DBUILD_CMAKE_TESTING=ON" to enable running cmake build system tests with ctest. Change-Id: I0a32e2d1771c9bbb0df013d0d955a9b58b1d4b79 Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
Diffstat (limited to 'cmake/tests/features/CMakeLists.txt')
-rw-r--r--cmake/tests/features/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/cmake/tests/features/CMakeLists.txt b/cmake/tests/features/CMakeLists.txt
index 0208e3d890..7b76a4529f 100644
--- a/cmake/tests/features/CMakeLists.txt
+++ b/cmake/tests/features/CMakeLists.txt
@@ -40,3 +40,5 @@ include(QtPostProcess)
## Print a feature summary:
feature_summary(WHAT PACKAGES_FOUND PACKAGES_NOT_FOUND FATAL_ON_MISSING_REQUIRED_PACKAGES)
+
+add_executable(features ../main.cpp)