summaryrefslogtreecommitdiffstats
path: root/examples/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2021-11-25 11:08:01 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-12-03 08:51:41 +0000
commit0245de5754785ff3fedb0addbf83e13cf90e76bf (patch)
tree9bc777f5702151493b8851a9d1d9b76ae87a4c5b /examples/corelib/CMakeLists.txt
parent8cd6a0840e9f0fca329a40fdfc72aadb0aeea6ba (diff)
Add example showing the benefits of using bindable properties
Added two examples for modeling a subscription service: signal/slot connection-based and bindable property-based. The examples are based on the example from Fabian's Qt WS talk about the bindable properties. Task-number: QTBUG-97655 Change-Id: I0345913b8b6e5c40b8477e128d36483598bdfcaa Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Ivan Solovev <ivan.solovev@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> (cherry picked from commit cee89e70a6011c3fcae29ad95d5fec4b2026d055) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/corelib/CMakeLists.txt')
-rw-r--r--examples/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/corelib/CMakeLists.txt b/examples/corelib/CMakeLists.txt
index 08b44649b7..30e2c8cd1f 100644
--- a/examples/corelib/CMakeLists.txt
+++ b/examples/corelib/CMakeLists.txt
@@ -1,5 +1,6 @@
# Generated from corelib.pro.
+add_subdirectory(bindableproperties)
add_subdirectory(ipc)
add_subdirectory(mimetypes)
add_subdirectory(serialization)