summaryrefslogtreecommitdiffstats
path: root/examples/corelib/ipc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 15:24:45 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 09:38:28 +0200
commit74cb331af3cfe723ae16cd1b00c9dd9291b4e7e9 (patch)
tree0f4ee41beba41f67a2ea0bb6c0134843a32c9ab6 /examples/corelib/ipc/CMakeLists.txt
parentd98a6d0463fd00e5463828b6a3e4e20db7d6d63e (diff)
CMake: Regenerate examples
Change-Id: I1c51b10af4e2b26f54740f257164c56a0e2a03ce Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/corelib/ipc/CMakeLists.txt')
-rw-r--r--examples/corelib/ipc/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/examples/corelib/ipc/CMakeLists.txt b/examples/corelib/ipc/CMakeLists.txt
index b134a3aa17..29a8d4f592 100644
--- a/examples/corelib/ipc/CMakeLists.txt
+++ b/examples/corelib/ipc/CMakeLists.txt
@@ -1,14 +1,12 @@
# Generated from ipc.pro.
-
+if(NOT TARGET Qt::Widgets)
+ return()
+endif()
if(QT_FEATURE_sharedmemory)
add_subdirectory(sharedmemory)
endif()
-
-if(TARGET Qt::Network)
-
- if(QT_FEATURE_localserver)
- add_subdirectory(localfortuneserver)
- add_subdirectory(localfortuneclient)
- endif()
+if(QT_FEATURE_localserver AND TARGET Qt::Network)
+ add_subdirectory(localfortuneserver)
+ add_subdirectory(localfortuneclient)
endif()