summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/queuedcustomtype/window.cpp
diff options
context:
space:
mode:
authorGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2019-01-29 12:09:22 +0100
committerGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2019-02-02 02:31:05 +0000
commit7847e6bc02552fa7fc7f518e5cb3336f667b5a6d (patch)
treeda01b34b0001983893ab96bebc0db4b60584c637 /examples/corelib/threads/queuedcustomtype/window.cpp
parent2bc362c9fa37455afbeb56e5f1852188ede3eab4 (diff)
Enable deprecation warnings by default
With Qt 6 in sight, people need to start moving away from their deprecated APIs, as we want to remove them all in 6.0. We are marking deprecated APIs with deprecation attributes, but by default we're disabling deprecation warnings, making them an opt-in by the user. We need to do the opposite: make deprecation warnings enabled by default, and have an opt-out define. [ChangeLog][QtCore][Important Behavior Changes] Qt now enables by default warnings when using APIs marked as deprecated. It is possible to disable such warnings by defining the QT_NO_DEPRECATED_WARNINGS macro. The old QT_DEPRECATED_WARNINGS macro which was used to enable this warning now has no effect (warnings are automatically enabled). Task-number: QTBUG-73048 Change-Id: Ie2b024fd667eb876b6ac9054cbbbc5a455cb9d5c Reviewed-by: Kai Koehne <kai.koehne@qt.io> Reviewed-by: Lars Knoll <lars.knoll@qt.io> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'examples/corelib/threads/queuedcustomtype/window.cpp')
0 files changed, 0 insertions, 0 deletions