summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/semaphores/CMakeLists.txt
diff options
context:
space:
mode:
authorElias Hautala <elias.hautala@qt.io>2023-08-14 10:06:33 +0300
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-08-28 13:00:58 +0000
commit901c8b599df63eb1c35d80fb49a681288127a5b1 (patch)
treee26882207ef70d3473b19cd7eb909685730e6203 /examples/corelib/threads/semaphores/CMakeLists.txt
parentde86906e4fc3377be700ec4ac67a11cdb4190967 (diff)
Exclude some examples from Android build
Excludes dnslookup, waitconditions, semaphores, cbordump, savegame, convert, pingpong and complexpingpong examples from Android build because of missing Qui and Quick dependenies. Task-number: QTBUG-111933 Change-Id: Ied01f62ee61a9220dcb44c13fda46f6a5e158293 Reviewed-by: Rami Potinkara <rami.potinkara@qt.io> Reviewed-by: Ville Voutilainen <ville.voutilainen@qt.io> (cherry picked from commit 39a5ed4bdd348d3cd18a08d322b48d85e8d116e8) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/corelib/threads/semaphores/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/semaphores/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/corelib/threads/semaphores/CMakeLists.txt b/examples/corelib/threads/semaphores/CMakeLists.txt
index bccf6e1e37..fee3f7a541 100644
--- a/examples/corelib/threads/semaphores/CMakeLists.txt
+++ b/examples/corelib/threads/semaphores/CMakeLists.txt
@@ -4,6 +4,10 @@
cmake_minimum_required(VERSION 3.16)
project(semaphores LANGUAGES CXX)
+if (ANDROID)
+ message(FATAL_ERROR "This project cannot be built on Android.")
+endif()
+
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()