summaryrefslogtreecommitdiffstats
path: root/examples/dbus/complexpingpong/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-21 09:55:46 +0100
committerKai Köhne <kai.koehne@qt.io>2022-01-24 14:00:00 +0100
commit57402ffb9bb5baa89907b3f1a4ea8e9e77d9802d (patch)
tree5490bc4f387fdb550642980d3f4bac089bd3a5fe /examples/dbus/complexpingpong/CMakeLists.txt
parentdfc1728e7ba1d159c2606cc9fb9571782345c62d (diff)
Examples: Remove unneeded CMake options
CMAKE_INCLUDE_CURRENT_DIR is not necessary anymore for moc since CMake 3.8: https://cmake.org/cmake/help/latest/release/3.8.html#other-changes CMAKE_AUTORCC should not be used anymore. Instead, we now use qt_add_resources() or similar Enable CMAKE_AUTOUIC only if .ui files are present. Pick-to: 6.3 Task-number: QTBUG-87643 Change-Id: I835e2994cd5dba9918136999499b9077961b616c Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/dbus/complexpingpong/CMakeLists.txt')
-rw-r--r--examples/dbus/complexpingpong/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/examples/dbus/complexpingpong/CMakeLists.txt b/examples/dbus/complexpingpong/CMakeLists.txt
index 7302d7b591..88a7764a51 100644
--- a/examples/dbus/complexpingpong/CMakeLists.txt
+++ b/examples/dbus/complexpingpong/CMakeLists.txt
@@ -1,11 +1,7 @@
cmake_minimum_required(VERSION 3.16)
project(complexpingpong LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")