summaryrefslogtreecommitdiffstats
path: root/examples/embedded/styleexample/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-18 19:26:24 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 13:03:01 +0000
commit64c6c943c7469c60e8d25c3efd630249740ae2f4 (patch)
tree4677ee8024b245d03ac647b11928930c1ad56304 /examples/embedded/styleexample/CMakeLists.txt
parenta0a94576fae26bcbbf3823a6ee4b554886e84925 (diff)
CMake: Add more examples
Change-Id: I7a8a3fd0a844a518592957fe07c6e707dd452d5f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/embedded/styleexample/CMakeLists.txt')
-rw-r--r--examples/embedded/styleexample/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/examples/embedded/styleexample/CMakeLists.txt b/examples/embedded/styleexample/CMakeLists.txt
new file mode 100644
index 0000000000..9c82adc99d
--- /dev/null
+++ b/examples/embedded/styleexample/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from styleexample.pro.
+
+#####################################################################
+## styleexample Binary:
+#####################################################################
+
+add_qt_executable(styleexample
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/embedded/styleexample"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/embedded/styleexample"
+ SOURCES
+ main.cpp
+ stylewidget.cpp stylewidget.h stylewidget.ui
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(styleexample "styleexample" PREFIX "/" FILES
+ files/add.png
+ files/application.qss
+ files/blue.qss
+ files/khaki.qss
+ files/nature_1.jpg
+ files/nostyle.qss
+ files/remove.png
+ files/transparent.qss)
+