summaryrefslogtreecommitdiffstats
path: root/examples/network/bearermonitor/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 08:15:50 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 18:50:39 +0000
commit76108058796bf0884f6fd128d81f1bc49f9a56af (patch)
tree1c5f0740ca3217f3d11cf7c684143bbb0da0f336 /examples/network/bearermonitor/CMakeLists.txt
parent465949420a877099247d94dd4db54d19ca5a9a7c (diff)
Regenerate examples
Change-Id: I04b2adbe370ffea81d7787ad90e4ae69d2c165cb Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/network/bearermonitor/CMakeLists.txt')
-rw-r--r--examples/network/bearermonitor/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/examples/network/bearermonitor/CMakeLists.txt b/examples/network/bearermonitor/CMakeLists.txt
index eb992a0c58..4e8bfca813 100644
--- a/examples/network/bearermonitor/CMakeLists.txt
+++ b/examples/network/bearermonitor/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/network/bearermonitor")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -30,6 +30,12 @@ target_link_libraries(bearermonitor PUBLIC
Qt::Widgets
)
+if(WIN32)
+ target_link_libraries(bearermonitor PUBLIC
+ ws2_32
+ )
+endif()
+
install(TARGETS bearermonitor
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"