summaryrefslogtreecommitdiffstats
path: root/examples/network/torrent/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-02-15 12:25:23 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-02-15 18:20:51 +0000
commit90860224c81afc2a1733117a7bea0d21f47b83fb (patch)
treeb796cccd401279f3d68715fd06d2bbfb795b0ab1 /examples/network/torrent/CMakeLists.txt
parentaa499b5fbce286ac31387e20037ba04ddb3547a2 (diff)
Fix CMake build of network/torrent example
The ui_XXX.h include did not match the location of the XXX.ui file, and AUTOUIC failed with "SRC:/addtorrentdialog.h" includes the uic file "ui_addtorrentform.h", but the user interface file "addtorrentform.ui" could not be found in the following directories "SRC:" While this could be fixed by adjusting the include paths properly, this would complicate the CMake project file, and we're dealing with an example where needless complexity would cloud comprehensibility. Move the .ui file next to corresponding source files instead. This removes the need for any special cases in CMakeLists.txt, and we can remove .prev_CMakeLists.txt. Fixes: QTBUG-87457 Change-Id: Ic2dec5ded7100e22d5afc571efc4b009bc62e41c Reviewed-by: Kai Koehne <kai.koehne@qt.io> (cherry picked from commit 0c51a8756377c40180619046d07b35718fcf1784) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/network/torrent/CMakeLists.txt')
-rw-r--r--examples/network/torrent/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/examples/network/torrent/CMakeLists.txt b/examples/network/torrent/CMakeLists.txt
index 7eea3d02bc..0d1f6735e3 100644
--- a/examples/network/torrent/CMakeLists.txt
+++ b/examples/network/torrent/CMakeLists.txt
@@ -22,10 +22,10 @@ find_package(Qt6 COMPONENTS Widgets)
qt_add_executable(torrent
addtorrentdialog.cpp addtorrentdialog.h
+ addtorrentform.ui
bencodeparser.cpp bencodeparser.h
connectionmanager.cpp connectionmanager.h
filemanager.cpp filemanager.h
- forms/addtorrentform.ui
main.cpp
mainwindow.cpp mainwindow.h
metainfo.cpp metainfo.h
@@ -39,7 +39,6 @@ set_target_properties(torrent PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_include_directories(torrent PUBLIC forms) # special case
target_link_libraries(torrent PUBLIC
Qt::Core
Qt::Gui