summaryrefslogtreecommitdiffstats
path: root/examples/network/torrent/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-18 19:26:24 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 13:03:01 +0000
commit64c6c943c7469c60e8d25c3efd630249740ae2f4 (patch)
tree4677ee8024b245d03ac647b11928930c1ad56304 /examples/network/torrent/CMakeLists.txt
parenta0a94576fae26bcbbf3823a6ee4b554886e84925 (diff)
CMake: Add more examples
Change-Id: I7a8a3fd0a844a518592957fe07c6e707dd452d5f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/network/torrent/CMakeLists.txt')
-rw-r--r--examples/network/torrent/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/examples/network/torrent/CMakeLists.txt b/examples/network/torrent/CMakeLists.txt
new file mode 100644
index 0000000000..f8cbc071ff
--- /dev/null
+++ b/examples/network/torrent/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from torrent.pro.
+
+#####################################################################
+## torrent Binary:
+#####################################################################
+
+add_qt_executable(torrent
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/torrent"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/torrent"
+ SOURCES
+ addtorrentdialog.cpp addtorrentdialog.h
+ bencodeparser.cpp bencodeparser.h
+ connectionmanager.cpp connectionmanager.h
+ filemanager.cpp filemanager.h
+ forms/addtorrentform.ui
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ metainfo.cpp metainfo.h
+ peerwireclient.cpp peerwireclient.h
+ ratecontroller.cpp ratecontroller.h
+ torrentclient.cpp torrentclient.h
+ torrentserver.cpp torrentserver.h
+ trackerclient.cpp trackerclient.h
+ INCLUDE_DIRECTORIES
+ forms # special case
+ LIBRARIES
+ Qt::Network
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(torrent "icons" PREFIX "/" FILES
+ icons/1downarrow.png
+ icons/1uparrow.png
+ icons/bottom.png
+ icons/exit.png
+ icons/peertopeer.png
+ icons/player_pause.png
+ icons/player_play.png
+ icons/player_stop.png)
+