summaryrefslogtreecommitdiffstats
path: root/examples/opengl/2dpainting/CMakeLists.txt
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing <johan.helsing@qt.io>2020-02-04 11:47:39 +0100
committerJohan Klokkhammer Helsing <johan.helsing@qt.io>2020-02-18 09:22:51 +0100
commit00eeed234f7c4cfc357b17424e0dcd714ff65e70 (patch)
tree19f93238e01638c519dbf6a15bd20768fab39aa6 /examples/opengl/2dpainting/CMakeLists.txt
parent077959972b6eb6fab55d08f955e4eeade48c09a9 (diff)
Move QOpenGLWidget from QtOpenGL to its own module
Same pattern as QtQuickWidgets. Gets rid of QtOpenGL's dependency on QtWidgets. Task-number: QTBUG-74409 Change-Id: I4f9b55c23e25a1e0519734037b768a16e870c7d2 Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'examples/opengl/2dpainting/CMakeLists.txt')
-rw-r--r--examples/opengl/2dpainting/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/opengl/2dpainting/CMakeLists.txt b/examples/opengl/2dpainting/CMakeLists.txt
index 1144830659..31f8005a19 100644
--- a/examples/opengl/2dpainting/CMakeLists.txt
+++ b/examples/opengl/2dpainting/CMakeLists.txt
@@ -15,6 +15,7 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
find_package(Qt6 COMPONENTS OpenGL)
+find_package(Qt6 COMPONENTS OpenGLWidgets)
add_qt_gui_executable(2dpainting
glwidget.cpp glwidget.h
@@ -27,6 +28,7 @@ target_link_libraries(2dpainting PUBLIC
Qt::Core
Qt::Gui
Qt::OpenGL
+ Qt::OpenGLWidgets
Qt::Widgets
)