summaryrefslogtreecommitdiffstats
path: root/examples/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-04 10:41:57 +0200
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-07 07:22:17 +0000
commitd8c3375dbd0bc4327c4da3df2433f965058d1da8 (patch)
treec2886dd0baf5a27c0d35bcb6fb0b949d8ea68274 /examples/opengl/CMakeLists.txt
parent331d1cf9fdeaf0d95ac601c460ebcd3e77de8376 (diff)
cmake: add examples/opengl
Fixes: QTBUG-78164 Change-Id: Iccc8bb1354d2362c950de17a6c00e00f95272967 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'examples/opengl/CMakeLists.txt')
-rw-r--r--examples/opengl/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/opengl/CMakeLists.txt b/examples/opengl/CMakeLists.txt
new file mode 100644
index 0000000000..53f6329463
--- /dev/null
+++ b/examples/opengl/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Generated from opengl.pro.
+
+add_subdirectory(hellowindow)
+add_subdirectory(paintedwindow)
+add_subdirectory(qopenglwindow)
+if(TARGET Qt::Widgets)
+ add_subdirectory(contextinfo)
+ add_subdirectory(threadedqopenglwidget)
+ add_subdirectory(2dpainting)
+ add_subdirectory(hellogl2)
+ add_subdirectory(qopenglwidget)
+ add_subdirectory(cube)
+ add_subdirectory(textures)
+ add_subdirectory(hellogles3)
+ add_subdirectory(computegles31)
+endif()